Как использовать HotSpot на MikroTik для рекламы

Давайте подумаем, что сегодня умеет делать ваш Wi-Fi роутер в заведениях, кроме как раздавать интернет…?

Сегодня 95% посетителей имеют мобильные гаджеты и, приходя в заведения, подключаются к бесплатной сети Wi-Fi. Оказывается, что обычный роутер также можно заставить работать на благо бизнеса. Используя базовый функционал hotspot в устройствах MikroTik, можна выводить посетителю при подключении к публичной сети Wi-Fi страницу-заглушку, стилизованную под ваш бренд. На ней также можно разместить как приветствие, так и материалы рекламного характера, например, информацию о текущих акциях и скидках. Но со временем сопровождение парка таких устройств начинает доставлять дискомфорт, так как при каждом изменении или новой рекламной кампании необходимо вручную заливать файлы заглушки на микротик. А если этих устройств несколько и они находят на разных объектах… ?

Предлагаем автоматизировать этот рутинный процесс с помощью сервиса WiFi Point. Данный сервис превратит обычный wi-fi кафе\офиса\торгового центра в мощный рекламный инструмент. От вас не потребуется много знаний или затрат на дорогие решения и оборудование. Все необходимое уже есть в базовой поставке роутеров MikroTik.

WiFi-Point

Рис.1. Внешний вид сервиса WiFi-Point

.

Сервис WiFi Point позволяет:

  • персонализировать ваш публичный Wi-Fi;
  • управлять несколькими площадками, не тратя много времени, удаленно из админпанели;
  • провести идентификацию гостя по номеру телефона;
  • предоставить платный доступ на основе ваучеров;
  • ограничить время/трафик/скорость для каждого гостя, чтобы разделить канал между всеми гостями;
  • проводить рекламные кампании среди гостей вашего заведения;
  • проводить опросы среди гостей;
  • ограничить использование вашей публичной сети, согласно режима работы заведения;
  • иметь статистику посещения вашего заведения.

 Приступим к обзору и настройке. В данной статье мы рассмотрим настройку роутера RB751 от MikroTik. Однако, все эти же действия можно выполнить и с любым другим роутером этого вендора.

Давайте все подключим и начнем.

Чтобы подключиться к роутеру, нам понадобится патчкорд и ноутбук/компьютер под управлением OS Windows. У роутеров MikroTik, также есть и веб-интерфейс, однако, через него не так удобно работать, поэтому мы воспользуемся штатной утилитой для настройки MikroTik  —  Winbox. Последнюю версию этой утилиты можно скачать на официальном сайте производителя.

 1. Подключение

Подключите ваш компьютер ко второму порту роутера. А в первый включите кабель интернет-провайдера или вышестоящего роутера.

Подключение

Рис.2. Подключение роутера к компьютеру и сети

.

Запустите WinBox.

Если на прошлом шаге вы все сделали верно, подключили роутер к компьютеру и подали питание на роутер, то на вкладке Neighbors вы увидите свой роутер.

Если там пусто  —  убедитесь, что все подключили верно.

Верное подключение

Рис.3. МАК роутера на вкладке Neighbors

.

Выберите мак вашего роутера, затем нажмите Connect.

По умолчанию, логин для входа admin, а пароль отсутствует.

При первом успешном входе вас встретит следующая табличка:

Сообщение при успешном входе

Рис.4. Сообщение при первом успешном входе

.

Здесь описаны стандартные параметры, которые будут применены. Вы можете согласиться или отказаться. В случае отказа, вам необходимо будет выполнить базовую настройку роутера самостоятельно. Мы же рассмотрим пример использования базовых настроек MikroTik для работы hotspot.

 Итак, выбираем ОК и проверяем, что настройки применились верно.

1 порт  — WAN, через него наш роутер получает интернет. По-умолчанию, здесь настроен DHCP клиент. Проверим, что все работает.
Войдите в меню IP > DHCP Client

IP DHCP Client

Рис.5. Окно DHCP Client

.

Как можно видеть на картинке, у нас есть 1 DHCP клиент, который получил адрес, ДНС и все необходимое. Также через него у нас настроен маршрут по умолчанию.

Чтобы убедиться, что интернет работает, откроем Tools > Ping

Проверка Интернета

Рис.6. Проверка работы Интернета

.

В поле Ping To укажем, например, google.com, и запустим пинг.

Результат как на картинке покажет, что интернет на роутере есть, можно идти дальше.

Обновление прошивки.

Компания MikroTik регулярно выпускает обновления для своих роутеров, поэтому важно чтобы на роутере была последняя стабильная прошивка.

Обновим ее.

В меню System > Packages можно через интернет обновить прошивку.

Список доступных прошивок

Рис.7. Перечень доступных прошивок

.

Выбираем Check for Updates и, в появившемся окне, в поле Channel выбираем Stable.

Выбор версии прошивки

Рис.8. Обновление прошивки

.

Если у вас стоит не последняя версия, то вам будет предложен Changelog последней стабильной версии и доступна кнопка Download&Install.

Жмем ее, роутер скачает файл прошивки и отправится на перезагрузку. Через 2 минуты все будет готово. Как только прошивка окончится, ваш роутер снова появится в Winbox Neighbors

Дата и время

После обновления также необходимо, чтобы на роутере было корректное время.

Перейдем в меню System > CLOCK и укажем правильный часовой пояс.

Настройка даты и времени

Рис.9. Настройка времени

.

Также, перейдем в меню System > SNTP Client

SNTP Client

Рис.10. Настройка SNTP Client

.

Необходимо включить все так, как на картинке. Как только вы сохраните настройки, роутер заменит ДНС-имена на IP и проведет синхронизацию времени. Также он будет синхронизироваться каждый раз, когда роутер перезагружается.

Настройка гостевого интерфейса Wi-Fi

По умолчанию, все порты и Wi-Fi интерфейс объединены в один мост. Это не совсем удобно в нашем случае, поэтому немного поправим эти настройки.

Перейдем в меню Bridge и в одноименной вкладке создадим новый мост.

Создание моста

Рис.11. Создание нового моста

.

В окне добавления моста можем изменить имя с Bridge1 на Wi-Fi-bridge.

Перейдем на вкладку STP и выберем Protocol mode: none.

Выбор параметров моста

Рис.12. Настройка моста

.

На этом создание моста завершено.

- Создание моста не обязательно, но если у вас возникнет необходимость подключить дополнительные Wi-Fi интерфейсы или дополнительные антенны, то ввести их в работу можно будет минимальной настройкой со стороны антенн и добавлением нового порта в этот мост.

Назначим нашему Wi-Fi интерфейсу новый мост.

Перейдем во вкладку Ports

Выбор нового моста

Рис.13. Назначение интерфейсу нового моста

.

Как можно видеть на картинке, наш беспроводной интерфейс сейчас принадлежит к первому мосту, из стандартной конфигурации.

Двойной клик по нужному интерфейсу — и мы видим уже настройки принадлежности к мосту.

Меняем в поле Bridge значение на новый, только что созданный Wi-Fi-bridge и сохраняемся.

Сохранение настроек моста

Рис.14. Подтверждение настроек моста

.

Настроим наш беспроводной интерфейс.

Перейдем в меню Interfaces и откроем wlan1

Вкладка Wireless — сердце настроек Wi-Fi

Параметры беспроводного интерфейса

Рис.15. Настройка беспроводного интерфейса

.

Укажите обязательные настройки:

Mode: ap bridge

band 2GHz-B/G/N

channel width: 20/40 MHz

SSID = название сети, которое увидят гости.

security profile = default — это параметры защиты сети. Оставить так, чтобы Wi-Fi был без пароля.

Остальные настройки требуют более детального изучения.

Если вокруг вас есть много других беспроводных сетей, рекомендуется изменить параметр Frequency с Авто на другой.

В результате данных настроек ваша беспроводная сеть станет доступной для подключения, однако, еще не готова принимать гостей.

Переходим к настройке Hotspot

Для корректной работы гостей и других устройств в вашем заведении, мы настраивали разные мосты. Теперь настроим так же и разные подсети.

Давайте выберем для гостей отдельную подсеть, например 10.10.10.0/24

Если у вас эта подсеть занята, используйте другую серую подсеть.

И, наконец, создадим хотспот в этой сети.

Перейдем в IP > Hotspot

Окно Нotspot

Рис.16. Окно настроек Нotspot

.

Здесь пока пусто. Запустим мастер настройки и укажем базовые настройки.

Шаг первый — интерфейс для гостей — Wi-Fi-bridge

1й этап настройки

Рис.17. Выбор гостевого интерфейса

.

Шаг второй — подсеть.

2й этап настройки

Рис.18. Выбор подсети

.

Укажем подсеть, которую мы заготовили ранее.

10.10.10.1/24

В этом случае 1 адрес будет назначен роутеру, а адреса с 2 по 254 отданы гостям.

Чекбокс Masquerade Network создаст правило для NAT, чтобы у этой подсети был выход в интернет.

Шаг третий — какие адреса выдавать гостям.

3й этап настройки

Рис.19. Адреса для гостей

.

Если оставить так, то все свободные адреса будут розданы гостям. Что, собственно, нам и нужно.

Шаг четвертый — сертификат — не изменяем ничего.

4й этап настройки

Рис.20. Настройка сертификата

.

Шаг пятый — SMTP оставляем по умолчанию

5й этап настройки

Рис.21. SMTP по умолчанию

.

Шаг шесть — ДНС сервер.

6й этап настройки

Рис.22. Настройка ДНС сервера

.

Укажем тот адрес, который назначили нашему роутеру в гостевой сети. В нашем случае 10.10.10.1

Шаг семь — ДНС имя для нашего сервиса.

7й этап настройки

Рис.23. Настройка имени ДНС-сервера

.

Укажем a.wi-fi-point.com

Шаг 8 — оставить без изменений.

Создание хотспота завершено, осталось внести немного изменений в его настройки, которые мастер не спрашивал на этапе первоначальной настройки.

1. Переименуем хотспот.

Откроем System > RouterBoard

Рис.24. Информация об устройстве

.

Cкопируем поле serial number, затем внесем его в поле Name нашего хотспота.

Изменение имени

Рис.25. Переименование хотспота

.

Должно получиться как на картинке, только с вашим серийным номером.

2. Ограничим количество адресов на устройство — 1

Здесь все, далее перейдем во вкладку User Profiles > default

Профиль пользователя

Рис.26. Настройка профиля пользователя

.

1. Установим keep-alive timeout, чтобы роутер закрывал неиспользуемые сессии через 5 минут

2. Установим MAC-Cookie Timeout 1d 00:00:00

Перейдем во вкладку Server Profiles

Профиль сервера

Рис.27. Окно профиля сервера

.

Выберем наш профиль, обычно называется hsprof1.

Откроем вкладку Login

Логин

Рис.28. Настройка логина

.

Установим все, как на картинке.

Перейдем во вкладку Radius и тоже установим рекомендованные параметры, как на картинке

Настройка Radius

Рис.29. Параметры Radius

.

Настройка профилей окончена.

Настройка Walled Garden IP List

Для корректной работы с сервисом необходимо, чтобы гости могли без авторизации иметь доступ к следующим адресам:

DNS Host: c.wi-fi-point.com

DNS Host: a.wi-fi-point.com

DNS Host: wi-fi-point.com

DNS Host: api.wi-fi-point.com

Чтобы сделать быстро, вот несколько команд

/ip hotspot walled-garden ip add dst-host=c.wi-fi-point.com
/ip hotspot walled-garden ip add dst-host=a.wi-fi-point.com
/ip hotspot walled-garden ip add dst-host=wi-fi-point.com
/ip hotspot walled-garden ip add dst-host=api.wi-fi-point.com

Откройте окно NEW Terminal и вставьте это туда. Результатом выполнения будет создание 4 правил в Walled Garden IP list

4 Правила Valled_Garden

Рис.30. Правила Valled_Garden

.

Страница авторизации

Далее, необходимо выполнить замену стандартной страницы авторизации на страницу авторизации для WiFi Point. Откроем меню System – Scripts. Далее нажимаем кнопку создать скрипт “+”.

В форме создания скрипта заполним поля:

В поле Name введем ReplaceLogin. В поле Source вставим код:

/tool fetch url=”http://c.wi-fi-point.com/firmware/routeros/login” dst-path=”login”; /import file-name=login; /

 

Применим созданный скрипт нажав кнопку Apply, а после выполним замену приветственной страницы нажав Run Script.

Замена логина

Рис.31. Замена приветственной страницы

 

Ограничения скорости

Сервис имеет функционал нарезки скорости для гостей. Это предусмотрено в целях предоставления более качественного сервиса, путем разделения канала между всеми гостями для комфортного пользования. Настройки полосы пропускания для гостей находятся в Личном кабинете, в разделе Площадки.

Однако, для корректной работы правил шейпера, необходимо также внести изменения в стандартные настройки шейперов на роутере.

Откроем меню Queues

Перейдем во вкладку Queue Types

Выберем пункт default и изменим поле kind на sfq

То же необходимо сделать и с default-small

В результате получится вот так.

Изменение стандартных настроек шейперов

Рис.32. Изменение настроек шейперов

.

RADIUS

Авторизация гостей на сервисе Wi-Fi Point происходит по RADIUS.

Поэтому нам необходимо настроить связь нашего роутера и сервиса по этому протоколу.

Открываем меню Radius и создаем новый инстанс.

Настройка RADIUS

Рис.33. Настройка протокола RADIUS

.

Выбираем сервис Hotspot, другие оставляем пустыми

Укажем IP RADIUS-севера wi-fi-point: 18.197.163.142

Secret: wfp123

Timeout 10000

На этом настройка RADIUS завершена.

Настройка обновления информации о площадке.

Чтобы иметь возможность видеть дополнительную статистику на странице вашей площадки, необходимо добавить еще один скрипт, теперь уже в планировщик.

Открываем System > Scheduler

Добавляем новое правило в планировщик

Schedule

Рис.34. Добавление правила в планировщик

.

Имя: mon_status

Interval: 00:01:00

On Event:

:local mac [system routerboard get serial-number];:if ( [system routerboard get routerboard] = yes ) do {
:set mac [system routerboard get serial-number]
} else {
:set mac [interface ethernet get ether1 mac-address]
};/tool fetch keep-result=no mode=http address=c.wi-fi-point.com host=c.wi-fi-point.com src-path=(“status\?type=routeros&station_id=$mac&identity=”.[/system identity get name].”&curtime=”.[/system clock get time].”&uptime=”.[/system resource get uptime].”&cpu_load=”.[/system resource get cpu-load].”&board_name=”.[/system resource get board-name].”&free_memory=”.[/system resource get free-memory])

Настройка аккаунта администратора

Как вы помните, по умолчанию роутеры MikroTik идут без пароля на вход. Это нельзя оставлять так, чтобы вредители или “доброжелатели” не сломали ваш сервис.

Давайте установим пароль для администратора.

Откроем System > Users

Перечень пользователей

Рис.35. Список пользователей

.

Выберем пользователя admin и установим ему новый пароль

Назначение нового пароля

Рис.36. Присвоение нового пароля

.

Сохраните этот пароль в надежном месте, чтобы не потерять доступ к вашему роутеру.

Настройка площадки

Роутер настроен и готов.

Теперь необходимо настроить площадку в Личном кабинете на сервисе wi-fi-point.com

Каждый роутер MikroTik соответствует одной площадке в системе WiFi Point. Поэтому, для дальнейшей работы нам необходимо создать новую площадку.

Чтобы создать площадку, нам необходимо определиться с шаблоном внешнего вида этой площадки.

В примере мы рассмотрим использование Demo шаблона, который вы потом без труда сможете отредактировать.

Открываем ЛК и переходим в WiFi Point Маркет

Wi-Fi-point-market

Рис.37. Окно Wi-Fi-point-market

.

 Выбираем один из бесплатных шаблонов, например “Шаблон Burger”. Жмем “Получить” и готово – у нас есть бесплатный шаблон.

Wi-Fi-point-burger

Рис.38. Выбор шаблона

.

Переходим в меню Wi-Fi Площадки > Все площадки и добавляем новую..

 Первым делом укажите название для этой площадки, чтобы ее можно было легко отличить от других.

Затем выбирайте шаблон, который получили в прошлом шаге.

Укажите цикл авторизации.

в WiFi Point есть несколько вариантов:

  • Быстрая – без смс и идентификации
  • SMS-Идентификация
  • Идентификация по ваучерам.

Более детально о каждом цикле авторизации можно прочитать в документации. Мы будем использовать простую авторизацию без смс и ввода номера ваучера. Поэтому выбираем вариант “Быстрая”

Далее, переходим на вкладку “Настройки устройства”. Выбираем тип “Mikrotik (RouterOS)” В качестве Station ID указываем серийный номер роутера. Он находится в меню System > RouterBoard На этом базовая настройка завершена. Сохраняем и закрываем настройки площадки.

Настройка завершена

Рис.39. Завершение настройки площадки

.

 Тест

Если подключиться к гостевой сети, то вас встретит страничка приветствия.

Страница приветствия гостевой сети

Рис.40.Тестовая страница приветствия

.

После нажатия на кнопку “Продолжить” на гостевом устройстве появится интернет.

 Внешний вид

Все элементы, изображения и текст можно редактировать в редакторе шаблонов. Для этого перейдите в меню Wi-Fi Площадки > Дизайны площадок и выберите необходимый шаблон.

Вкладка “Дизайн” поможет быстро изменить важные параметры, а макет предпросмотра сразу отобразит все изменения

Редактирование дизайна

Рис.41. Меню редактирования дизайна

 .

Теперь, благодаря несложным действиям, маршрутизатор MikroTik готов к работе и будет приносить реальную пользу вашему бизнесу. Подключившись к Wi-Fi клиент будет видеть страницу-заглушку с логотипом вашего бренда и информацией, которую вы хотите ему сообщить. Данный маршрутизатор можно установить в гостинице, учебном заведении или кафе, организовав доступ к сети интернет с просмотром рекламной информации, проведением опроса посетителей. Воспользоваться данным сервисом можно пройдя регистрацию на сайте WiFi Point, получив бесплатно пробный тест-драйв сервиса на целый месяц.

p.s. Если не удалось настроить по ручной инструкции, можно воспользоваться автоматической настройкой. Конфигурация устройства будет выполнена за несколько секунд автоматически.

 

Если Вы нашли ошибку в тексте, то выделите ее мышкой и нажмите Ctrl + Enter или нажмите здесь.

Сообщение об ошибке

Ошибка:

Ваш комментарий (не обязательно):

Да Отмена

Об авторе asp24