MikroTik PWR-Line AP – тест в реальных условиях

Ежедневно в эксплуатацию у нас в стране сдается сотни квартир, 40% из них с ремонтом, и лишь в 10% квартир уже проложена готовая слаботочная система, или проще говоря локальная сеть. Как же быть, если вы заселились в квартиру вашей мечты, расставили мебель, повесили телевизор, подключили ПК, и когда дело дошло до подключения жизненно важной коммуникации – интернет, выяснилось, что ни в одну из комнат UTP (витая пара) не проложен? А комнат две или три и даже самый мощный TP-Link Archer C6 не может добить из прихожей в дальнюю комнату? Ясное дело репитерам в современных сетях нет места, а тянуть кабель в комнату – значит разрушить дорогостоящий ремонт. Как быть, ведь смотреть 4К на новом ТВ охота, но сигнала нет!

Мне недавно попалась такая квартира, где от роутера сигнал еле добивал в дальнюю комнату, а разводки витой пары не было и в помине. Так как проложить кабель не было возможности, я решил прибегнуть к помощи MikroTik PWR-Line AP (PL7411-2nD).

MikroTik PWR-Line AP

Рис.1. MikroTik PWR-Line AP

 

Будучи наслышан о минусах стандарта Powerline (PCL), я решил изначально протестировать работу устройств через сетевые фильтры и напрямую. Для начала обновляем RouterOS до последней версии ветки Long-term, а также Firmware.

Лайфхак! Обновить firmware PCL чипа можно только через terminal помощью команды CLI:
interface pwr-line upgrade-firmware pwr-line1

Но, так как разработчики ПО для PWR-Line похоже забили на всё это дело – последним релизом Firmware является версия 1.4.0(24-20180515-CS) датирована 2018 годом.

Оба устройства будут настраиваться мостом, DHCP сервером является Mikrotik RB2011UiAS-2HnD-IN.

Создаём мост, добавляем порты:
/interface bridge
add name=bridge1 protocol-mode=none
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=pwr-line1
add bridge=bridge1 interface=ether1

Навешиваем адреса и маршрут для управления устройством в локальной сети, а также добавляем DNS для будущего обновления прошивки:
/ip address
add address=192.168.88.2/24 interface=bridge1 network=192.168.88.0
/ip route
add distance=1 gateway=192.168.88.1
/ip dns
set servers=8.8.8.8,8.8.4.4

Далее смотрим текущую конфигурацию интерфейса PWR-Line:
interface pwr-line> monitor
numbers: 0
                    name: pwr-line1
       connection-to-plc: ok
         tx-flow-control: no
         rx-flow-control: no
  plc-actual-network-key: 24262ca4c308ccd509e349d461a8a1dc
         plc-hw-platform: QCA7420
         plc-sw-platform: MAC
          plc-fw-version: 1.4.0(24-20180515-CS)
           plc-line-freq: 50Hz
       plc-zero-crossing: detected
                plc-role: central-coordinator
       plc-station-count: 1
                 plc-mac: 48:8F:5A:79:53:27
             plc-cco-mac: 48:8F:5A:79:53:27

И настраиваем авторизацию по шестнадцатизначному ключу сопряжения:
interface pwr-line configure plc-cco-selection-mode=auto network-
key=24262ca4c308ccd509e349d461a8a1dc

На втором устройстве повторяем конфигурацию, подставляем:
interface pwr-line configure plc-cco-selection-mode=auto network-key=24262ca4c308ccd509e349d461a8a1dc

Меняем ip адрес на следующий, и вуаля – PWR-Line готовы к тестированию. Итак, я решил провести три теста, чтобы проверить, как поведут себя PWR-Line при наличии помех. Условия проведения: канал 100 Мбит/с, алюминиевая проводка, сетевые фильтры.

Тест 1. Начну с самого простого, оба устройства находятся в одном сетевом фильтре.

MikroTik PWR-Line AP в режиме сопряжения

Рис.2. MikroTik PWR-Line AP в режиме сопряжения

 

Лафхак! Физическую скорость соединения между PWR-Line можно проверить лишь через terminal с помощью команды CLI:
/interface pwr-line> monitor 0
                    name: pwr-line1
       connection-to-plc: ok
         tx-flow-control: no
         rx-flow-control: no
  plc-actual-network-key: 24262ca4c308ccd509e349d461a8a1dc
         plc-hw-platform: QCA7420
         plc-sw-platform: MAC
          plc-fw-version: 1.4.0(24-20180515-CS)
           plc-line-freq: 50Hz
       plc-zero-crossing: detected
                plc-role: central-coordinator
       plc-station-count: 1
                 plc-mac: 48:8F:5A:79:53:27
             plc-cco-mac: 48:8F:5A:79:53:27
        plc-station-info: 48:8F:5A:79:5B:C7: first-bridged-address:48:8F:5A:79:5B:C6 phy-tx-rate:358Mbps phy-rx-rate:356Mbps

Тест 1: физическая скорость phy-tx-rate:358Mbps phy-rx-rate:356Mbps

Рис.3. Тест 1: физическая скорость phy-tx-rate:358Mbps phy-rx-rate:356Mbps

 

Результата как на скрине выше – можно добиться лишь на идеальной проводке, без автоматов и сетевых фильтров.

Тест 2. Ситуация посложнее:  central-coordinator и slave находятся в разных розетках  –  расстояние проводки 11 м.

PWR-Line в розетке

Рис.4. PWR-Line в розетке

 

PWR-Line смотрится как зарядное устройство ноутбука

Рис.4.1. PWR-Line смотрится как зарядное устройство ноутбука

 

Тест 2: физическая скорость phy-tx-rate: 280Mbps phy-rx-rate: 298Mbps

Рис.5. Тест 2: физическая скорость phy-tx-rate: 280Mbps phy-rx-rate: 298Mbps

 

Скорость в дуплексе уже 50/50 Мбит, но обычный пользователь вряд ли будет отгружать и загружать информацию одновременно на таких скоростях, поэтому, для просмотра фильмов в 4К симплекса 88 Мбит/с, будет предостаточно.

Тест 3. Итак, central-coordinator в сетевом фильтре, slave в розетке, длинна проводки – 9 м.

Mikrotik Powerline AP и Mikrotik RB2011UiAS-2HnD-IN

Рис.6. Mikrotik Powerline AP и Mikrotik RB2011UiAS-2HnD-IN

 

Тест 3: физическая скорость phy-tx-rate: 136Mbps phy-rx-rate: 105Mbps

Рис.7. Тест 3: физическая скорость phy-tx-rate: 136Mbps phy-rx-rate: 105Mbps

 

Шумы от сетевого фильтра очень сильно повлияли на скорость, и тем более непонятно почему загрузка так разнится с отдачей. К слову говоря, PLC интерфейс имеет всего лишь три настройки: PlcCcoSelectionMode ::= always | auto | never, и как бы я не менял местами настройки central-coordinator – slave, отдача всё равно осталась выше приёма.

Тест 4. Самые сложные условия, оба PWR-Line находятся в разных сетевых фильтрах, расстояние проводки – 10 м.

Тест 4: физическая скорость phy-tx-rate:60Mbps phy-rx-rate:74Mbps

Рис.7. Тест 4: физическая скорость phy-tx-rate: 60Mbps phy-rx-rate: 74Mbps

 

Два сетевых фильтра сильно повлияли на скорость между PWR-Line.

Предварительные тесты я провёл, теперь я спокойно мог приступить к установке на месте.

Ситуация на объекте  заказчика осложнялась тем, что розетка в комнате, и розетка где установлен роутер, а здесь им стал мощный двухдиапазонный Mikrotik hAP ac2 (RBD52G-5HacD2HnD-TC) находились на двух абсолютно разных автоматах.

Красным обозначен автомат на комнату, зелёным блок автоматов отвечающих за розетку возле роутера

Рис.9. Красным обозначен автомат на комнату, зелёным блок автоматов отвечающих за розетку возле роутера

 

Оба сетевых фильтра были заменены на удлинители с качественным кабелем и хорошими блоками розеток без автоматических выключателей.

Новый блок розеток и узел коммутации

Рис.10. Новый блок розеток и узел коммутации

 

Итак, длина кабеля составила 28 м, на пути только два автоматических выключателя, а переноски заменены на качественные. Качество соединения плавало от 235Mbps до 130 Mbps, как мне удалось выяснить, столь сильные потери возникают из-за БП DC 1 2в, 1,2 а для подсветки потолка.

Тест прокачки на объекте: физическая скорость

Рис.11. Тест прокачки на объекте: физическая скорость phy-tx-rate: 180Mbps phy-rx-rate: 191Mbps

 

Соединения в 180 Mbps хватило для прокачки реальных 77 Мбит/с на приём и 72 Мбит/с отдачи, что вполне удовлетворяло требованиям клиента – 4К контент без проблем воспроизводился на телевизоре, подключенном по кабелю к PWR-Line, к тому же в этой комнате отныне есть стабильное покрытие Wi-Fi. Конечно, на частоте 2,4 ГГц в шумном эфире не удалось добиться больше 42 Мбит/с на приём и 48 Мбит/с отдачи, но этого вполне хватит для комфортного сёрфинга на смартфоне.

MikroTik PWR-Line AP (PL7411-2nD)

Рис.12. MikroTik PWR-Line AP (PL7411-2nD) в режиме сопряжения

 

Рекомендую MikroTik PWR-Line AP (PL7411-2nD) всем, кто стоит перед тяжелым решением, как покрыть Wi-Fi удалённые комнаты и помещения, где не заложен UTP кабель. Технология Powerline поможет даже в самых безвыходных ситуациях!

Вас может заинтересовать

 
1099 грн 39.39 у.е.
Купить
 
1200 грн 43 у.е.
Купить
 
3338 грн 119.65 у.е.
Купить
 
2372 грн 85 у.е.
Купить

Если Вы нашли ошибку в тексте, то выделите ее мышкой и нажмите Ctrl + Enter или нажмите здесь.

Сообщение об ошибке

Ошибка:

Ваш комментарий (не обязательно):

Да Отмена

Об авторе Andrey_Kozhuhar